SOLIDWORKS Simulation – Running a Static Analysis Throws an “Abnormal pretension is detected” Error

EmailFacebookGoogle+LinkedInTwitterShare
Abnormal bolt pretension is detected during the modifying pretension cycle example error window
Abnormal bolt pretension is detected during the modifying pretension cycle. Would you like to stop the application and check the setting?

While running a static analysis in SOLIDWORKS Simulation an error window pops up that says, "Abnormal bolt pretension is detected during the modifying pretension cycle. Would you like to stop the application and check the setting?" What does this error mean and how do I fix it? There are a few reasons why this message is shown during the calculation time. At least two possible causes of this error are due to the boundary conditions that are applied. For instance:

  • The hole diameter is much larger than the input diameter in the bolt connector.
  • The material assigned in bolt connector and/or to the geometry is very soft.

The third reason I’ve seen this is because there is a gap between the geometry that the bolt is tightening. Please do not have an open gap! If you are leaving the gap for excluded geometry then use the no penetration condition with gap clearance.

location of the no penetration condition with gap clearance

If the gap is NOT ignored, then the solver will want to use Large Displacement calculation due to the movement of the geometry.

Now, each previous reason is fairly difficult to fall into because everyone models their geometry well and knows that bolt connectors should be setup properly for any reasonable results. With this in mind, even the best of us can forget to apply proper contact sets to all possible locations. Take this example of a cantilever beam (Figures 1 and 2):

figure 1 example cantilever beam in SOLIDWORKS simulation for fixing Abnormal bolt pretension is detected during the modifying pretension cycle
Figure 1: Example cantilever beam

figure 2 example cantilever beam in SOLIDWORKS simulation for fixing Abnormal bolt pretension is detected during the modifying pretension cycle

SOLIDWORKS Simulation part tree showing no penetration contact sets

We have applied a no penetration condition on the horizontal faces and suppressed the global condition. The two parts are touching each other, (there is no gap), and we still get the “Abnormal bolt pretension is detected during the modifying pretension cycle” error.

Why? Because we didn’t apply a no penetration contact set to the vertical faces where the bolt connector is. By switching the global condition to no penetration and suppressing the local contact set, the study will run fine. However, I wouldn’t recommend doing this on a larger assembly. This example is a simple two part assembly with simple geometry.

Ketul Patel
Simulation Specialist
Computer Aided Technology, LLC