Upgrade PDMWE before SolidWorks

EmailFacebookGoogle+LinkedInTwitterShare

With all the excitement of SOLIDWORKS 2009’s release – remember PDMWorks Enterprise 2008 or older versions cannot be used with SOLIDWORKS 2009.

Drat.